Bienvenido(a) a Alcance Libre 30/11/2022, 09:03

Alcance Libre Foros

 Índice del foro > Todo acerca de Linux > Redes y Servidores New Topic Post Reply
 Apache mod_rewrite activación
Tópico anterior Tópico siguiente
   
Designer
 05/19/15 12:51AM (Leído 1,792 veces)  

Nuevo

Estado: desconectado
Forum User

Identificado: 05/13/15
Mensajes: 6
Empezaré diciendo que el sistema es Centos 6.6 manejado por Plesk 12. La versión de Apache es la 2.2.15 y PHP 5.3. El caso es que no consigo activar módulo mod_rewrite para que funcionen las directivas .htaccess de las páginas web alojadas en el servidor.

Explico los pasos que he dado hasta el momento:

1º Edito el archivo de configuración de Apache:

PHP Formatted Code
# vi /etc/httpd/conf/httpd.conf


2º Localizo la línea > AllowOverride None y la sustituyo por AllowOverride All e indico el directorio base:

PHP Formatted Code
<Directory "/var/www/vhosts">
             Options FollowSymLinks
             AllowOverride All
<Directory>


3º Localizo la línea > AllowOverride controls what directives may be placed in .htaccess files y modifico el parámetro AllowOverride None a AllowOverride All:

PHP Formatted Code
AllowOverride All


4º Compruebo que está cargado el modulo mod_rewrite:

PHP Formatted Code
LoadModule rewrite_module modules/mod_rewrite.so


5º Reinicio el servidor Apache:

PHP Formatted Code
# service httpd restart


6º Genero el archivo phpinfo.php para comprobar si el módulo está cargado en la configuración:

PHP Formatted Code
<?php
phpinfo();
phpinfo(INFO_MODULES);
?>


Lo cargo en ejemplo.com/phpinfo.php y no muestra el bloque de módulos de Apache Loaded modules.

7º Realizando estas modificaciones, el servidor sigue registrando error 500 cuando habilito .htaccess y mod_rewrite en Joomla. Busco en Parallels.com - http://kb.sp.parallels.com/es/124 y apunta la resolución al problema:
Los archivos .htaccess pueden habilitarse añadiendo lo siguiente al archivo "/etc/httpd/conf.d/zz010_psa_httpd.conf":

PHP Formatted Code
AccessFileName .htaccess

<Directory "/var/www/vhosts">
Options +All
AllowOverride All
Order allow,deny
Allow from all
</Directory>


8º Reinicio apache:

PHP Formatted Code
# service httpd stop
# service httpd start


En este punto ya no se que más hacer para habilitar el módulo. ¿Véis que me haya saltado algún paso o me falta algo (es evidente que si) por configurar?

Gracias saludos
 
Profile Email
 Quote
Designer
 05/19/15 09:46AM  

Nuevo

Estado: desconectado
Forum User

Identificado: 05/13/15
Mensajes: 6
¡¡¡SOLUCIONADO!!!

Para quien le pueda ayudar, la solución está en la ruta:

PHP Formatted Code
<Directory /var/www/vhosts/*/httpdocs>
    Options FollowSymLinks
    AllowOverride All
</Directory>

#
# Note that from this point forward you must specifically allow
# particular features to be enabled - so if something's not working as
# you might expect, make sure that you have specifically enabled it
# below.
#

#
# This should be changed to whatever you set DocumentRoot to.
#
<Directory "/var/www/vhosts/*/
httpdocs">



De esta forma todo lo que está por debajo del directorio vhosts queda recojido por las directivas.
 
Profile Email
 Quote
Contenido generado en: 0.28 segundos New Topic Post Reply
 Todas las horas son CST. Hora actual 09:03 AM.
Tópico normal Tópico normal
Tópico Pegado Tópico Pegado
Tópico bloqueado Tópico bloqueado
Mensaje Nuevo Mensaje Nuevo
Tópico pegado con nuevo mensaje Tópico pegado con nuevo mensaje
Tópico bloqueado con nuevo mensaje Tópico bloqueado con nuevo mensaje
Ver mensajes anónimos 
Los usuarios anónimos pueden enviar 
Se permite HTML Filtrado 
Contenido censurado