Bienvenido(a) a Alcance Libre 01/10/2022, 15:06

Alcance Libre Foros

 Índice del foro > Todo acerca de Linux > Programas y Aplicaciones New Topic Post Reply
 xsane problema
Tópico anterior Tópico siguiente
   
manowar
 06/29/07 05:21PM (Leído 2,378 veces)  

Miembro Activo

Estado: desconectado
Forum User

Identificado: 02/26/07
Mensajes: 280
Localización:Santiago - Chile
Tengo un usuario con Centos 4.5 y conectada por usb un scaner epson perfection 1240, cero problema hasta algunos dias(antes de un update), pero desde entonces sucede lo siguiente:
En ocasiones no me reconoce la impresora como usuario regular(sin privilegios root) y cuando lo hace basta un reset y ya al ejecutar xsane me devuelve el mensaje "No se encontraon dispositivos".
Como root no hay problemas, pero ni de burro podria dejar al usuario ser root. Como salvo esta situacion. tengo la version 0.98 de xsane.

Saludos y haber que se puede obtener.
 
Profile Email Website
 Quote
manowar
 07/06/07 05:28PM  

Miembro Activo

Estado: desconectado
Forum User

Identificado: 02/26/07
Mensajes: 280
Localización:Santiago - Chile
en definitiva hace algunos lo solucione y paso a detallar la solucion, por a alguien le sirve;
El problema pasa porque el usuario(simple mortal) o tiene privilegios sobre el recurso scanner, nada nuevo.
Vamos primero veamos que se reconoce el scanner :
[root@aasena ~]# scanimage -L
device `epson:libusb:001:004' is a Epson Perfection1240 flatbed scanner
[root@aasena ~]#

Por algun momento crei que esta era la solucion :
http://www.xs4all.nl/~ljm/SANE-faq.html#47

Pero sorpresa no lo era, asi que me dirigi a ver el asunto por el lado de USB y este parrafo encontre la solucion:
http://www.xs4all.nl/~ljm/SANE-faq.html#83

en otras palabras esta linea me basto para solucionar el asunto :
chmod a+rw /proc/bus/usb/001/003
pero esto me dura hasta que reinicie mi Pc o apague el scanner, entonces me aburri de seguir leyendo cree un archivito en /usr/local/bin y agregue la linea en cuestion, le di permisos de ejecucion a el archivo y añadi la linea
/usr/local/bin/archivo_creado en /etc/rc.local

Y ya esta, tanto pero resulto, e todas maneras siempre hay mas formas de hacerlo, otra cosa esto fue con un Centos, Redhat y WhiteBox, en otros linux habra que editar el archivo /etc/security/console.perms o donde se encuentre este archivo.

Me voy a tomar una cerveza y se acabo el trabajo.
SALUD
 
Profile Email Website
 Quote
Contenido generado en: 0.08 segundos New Topic Post Reply
 Todas las horas son CDT. Hora actual 03:06 PM.
Tópico normal Tópico normal
Tópico Pegado Tópico Pegado
Tópico bloqueado Tópico bloqueado
Mensaje Nuevo Mensaje Nuevo
Tópico pegado con nuevo mensaje Tópico pegado con nuevo mensaje
Tópico bloqueado con nuevo mensaje Tópico bloqueado con nuevo mensaje
Ver mensajes anónimos 
Los usuarios anónimos pueden enviar 
Se permite HTML Filtrado 
Contenido censurado