Bienvenido(a) a Alcance Libre 27/01/2023, 07:42

Alcance Libre Foros

 Índice del foro > Todo acerca de Linux > Redes y Servidores New Topic Post Reply
 Problemas con postfix y algunos dominios!
Tópico anterior Tópico siguiente
   
al-serv
 11/22/13 09:58AM (Leído 5,038 veces)  

Miembro Activo

Estado: desconectado
Forum User

Identificado: 03/01/08
Mensajes: 641
Localización:Cataluña
hola!

hace unos dias que migre de Sendmail a postfix y no tenia ningún problema pero desde hace unos dias veo que me se quedan en la cola de envio, algun que otro mensaje y me pone lo siguiente;

timed out while sending message body

No se lo que debo de tocar para que lo envie bien... o es culpa de los otros servidores, me pasa con varios dominios así que sospecho que es cosa mia no???

Gracias!
 
Profile Email Website
 Quote
Joel Barrios Dueñas
 11/22/13 10:26AM  

Admin

Estado: desconectado
Site Admin

Identificado: 02/17/07
Mensajes: 1761
Localización:Mexico
Más bien publica el contenido de algunas cabeceras de los archivos en /var/spool/mqueue. Muy probablemente sea problema de otros servidores o direcciones de correo mal escritas. Pero la única forma de saberlo es viendo estados de mensajes sin entregar.
 
Profile Email Website
 Quote
al-serv
 11/22/13 10:29AM  

Miembro Activo

Estado: desconectado
Forum User

Identificado: 03/01/08
Mensajes: 641
Localización:Cataluña
pues en el log pone algo así:

Nov 22 17:21:51 server-linux postfix/smtp[6694]: E5B8541A80: enabling PIX workarounds: disable_esmtp delay_dotcrlf for forward10.nameresolvers.com[216.13.106.65]:25

en la cabecera pone algo así;

conversation with mail1.-----.com[62.x.x.x] timed out while sending message body

Son direcciones bien escritas y que hasta ahora no habian dado problemas..... es raro porque si lo mando desde una cuenta de gmail si que llegan bien! alguna idea??
 
Profile Email Website
 Quote
al-serv
 11/22/13 10:31AM  

Miembro Activo

Estado: desconectado
Forum User

Identificado: 03/01/08
Mensajes: 641
Localización:Cataluña
más log sobre este tema;

relay=mail2.-----.com[62.x.x.x]:25, delay=112173, delays=111811/0.07/182/181, dsn=4.4.2, status=deferred (conversation with mail2.-----.com[62.x.x.x] timed out while sending message body)
 
Profile Email Website
 Quote
Joel Barrios Dueñas
 11/22/13 02:04PM  

Admin

Estado: desconectado
Site Admin

Identificado: 02/17/07
Mensajes: 1761
Localización:Mexico
Esas son conexiones demoradas por problemas de conectividad o bien servidores de destino caídos.
 
Profile Email Website
 Quote
al-serv
 11/25/13 08:44AM  

Miembro Activo

Estado: desconectado
Forum User

Identificado: 03/01/08
Mensajes: 641
Localización:Cataluña
he hecho más pruebas y esta es mi conclusión al problema que sigo teniendo;

si envio solo texto sin adjunto les llega perfecto, a lo que adjunto alguna cosa es cuando se queda en el servidor ( posible configuración del clamav??? )

Pero solo me pasa con unos ciertos dominios ya que si lo envio a gmail o a mi mismo si que llegan bien.... He probado otro servidor con postfix y en ese si que llegan incluso los adjuntos y la configuración es la misma!

Alguna idea???? algun manual de como configurar clamav ( sin amavis ni mailscanner ?? )

P.D: el clamav esta actualizado y el servicio levantado!
 
Profile Email Website
 Quote
gutierrezr
 11/25/13 09:31AM  

Moderador

Estado: desconectado
Forum User

Identificado: 03/28/07
Mensajes: 179
No , el postfix su fin es enviar el correo a su destinatario , lo que veo es que los servidores a los que enviar tienen un filtro adelante como el caso del mensaje Pix Around , podría ser que ellos estén filtrando algún tipo de contenido.

como tienes el ping hacia esos servidores para comprobar la latencia?

sldss
 
Profile Email
 Quote
al-serv
 11/25/13 09:36AM  

Miembro Activo

Estado: desconectado
Forum User

Identificado: 03/01/08
Mensajes: 641
Localización:Cataluña
gracias por tu rapida respuesta!

el ping;

ttl=52 time=88.2 ms

Lo raro es que con adjuntos no llegue y sin adjuntos si que llegue, he desactivado que clamav analice adjuntos pero sigue igual! donde puedo mirar más??
 
Profile Email Website
 Quote
gutierrezr
 11/25/13 10:13AM  

Moderador

Estado: desconectado
Forum User

Identificado: 03/28/07
Mensajes: 179
Te pasa solo con ese dominio o con todos?
 
Profile Email
 Quote
al-serv
 11/25/13 10:16AM  

Miembro Activo

Estado: desconectado
Forum User

Identificado: 03/01/08
Mensajes: 641
Localización:Cataluña
con algunos, no todos ;( el mismo mensaje mandado a varios dominios en alguno ha fallado dando el mensaje;

timed out while sending message body
 
Profile Email Website
 Quote
al-serv
 11/25/13 10:28AM  

Miembro Activo

Estado: desconectado
Forum User

Identificado: 03/01/08
Mensajes: 641
Localización:Cataluña
he mirado y y también hay esto en el log;

delay=514, delays=152/0.03/181/180, dsn=4.4.2, status=deferred

creo que es algo de latencia como dices! y como soluciono esto??
 
Profile Email Website
 Quote
al-serv
 11/27/13 03:09PM  

Miembro Activo

Estado: desconectado
Forum User

Identificado: 03/01/08
Mensajes: 641
Localización:Cataluña
pues ya lo tengo resuelto!!!! Joel siento llevarte la contraria pero la culpa no es de los otros servidores, la culpa es del router y del MTU

Para resolverlo, solo tienes que adaptar la eth al MUT del router, puede ser 1480, 1492, etc... mirar en el manual del router y lo suele poner o en sant google jejeje! una vez lo saves solo tienes que poner en el fichero de sysconfig/network-scripts/icfcg-eth---- el MTU=14... y reiniciar el network para que aplique los cambios, sino también puedes hacer ifconfig ethx mtu 14.. y se aplica al instante! con esto ya tendría que ir y esperar que el propio postfix los empiece a sacar por si solo!

Espero que a alguien le sirva esto jejeje! me ha traído de cabeza la verdad!!
 
Profile Email Website
 Quote
Contenido generado en: 0.31 segundos New Topic Post Reply
 Todas las horas son CST. Hora actual 07:42 AM.
Tópico normal Tópico normal
Tópico Pegado Tópico Pegado
Tópico bloqueado Tópico bloqueado
Mensaje Nuevo Mensaje Nuevo
Tópico pegado con nuevo mensaje Tópico pegado con nuevo mensaje
Tópico bloqueado con nuevo mensaje Tópico bloqueado con nuevo mensaje
Ver mensajes anónimos 
Los usuarios anónimos pueden enviar 
Se permite HTML Filtrado 
Contenido censurado