Bienvenido(a) a Alcance Libre 31/01/2023, 04:14

Alcance Libre Foros

 Índice del foro > Todo acerca de Linux > Redes y Servidores New Topic Post Reply
 Como activar o reparar repos?
Tópico anterior Tópico siguiente
   
Oscar Hernández
 09/03/09 10:00AM (Leído 17,795 veces)  

Miembro Activo
working

Estado: desconectado
Forum User

Identificado: 03/29/07
Mensajes: 181
Localización:México D.F. /Del Alvaro Obregon
Saludos

Tengo una pregunta, como puedo activar o reparar los repos?

no he podido actualizar mi servidor, tengo 2 servidores con las mismas caracteristicas pero uno dejo de actualizar el otro si actualiza


ex yum.repos.d]# ls
CentOS-Base.repo Webmin.repo
rpmforge-release-0.3.6-1.el5.rf.i386.rpm
CentOS-Media.repo

[base]
name=CentOS-$releasever - Base
mirrorlist=http://mirrorlist.centos.org/?release=$releasever&arch=$basearch&repo=os
#baseurl=http://mirror.centos.org/centos/$releasever/os/$basearch/
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-5
enabled = 0

#released updates
[updates]
name=CentOS-$releasever - Updates
mirrorlist=http://mirrorlist.centos.org/?release=$releasever&arch=$basearch&repo=updates
#baseurl=http://mirror.centos.org/centos/$releasever/updates/$basearch/
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-5
enabled = 0

#packages used/produced in the build but not released
[addons]
name=CentOS-$releasever - Addons
mirrorlist=http://mirrorlist.centos.org/?release=$releasever&arch=$basearch&repo=addons
#baseurl=http://mirror.centos.org/centos/$releasever/addons/$basearch/
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-5
enabled = 0

#additional packages that may be useful
[extras]
name=CentOS-$releasever - Extras
mirrorlist=http://mirrorlist.centos.org/?release=$releasever&arch=$basearch&repo=extras
#baseurl=http://mirror.centos.org/centos/$releasever/extras/$basearch/
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-5
enabled = 0

#additional packages that extend functionality of existing packages
[centosplus]
name=CentOS-$releasever - Plus
mirrorlist=http://mirrorlist.centos.org/?release=$releasever&arch=$basearch&repo=centosplus
#baseurl=http://mirror.centos.org/centos/$releasever/centosplus/$basearch/



ex ~]# yum -y update
Loaded plugins: fastestmirror, tmprepo
Loading mirror speeds from cached hostfile
Setting up Update Process
No Packages marked for Update

Sabio no es aquel que dedica su vida a aprender sino el que la dedica a enseñar.
 
Profile Email Website
 Quote
Joel Barrios Dueñas
 09/03/09 01:17PM  

Admin

Estado: desconectado
Site Admin

Identificado: 02/17/07
Mensajes: 1761
Localización:Mexico
Intenta con yum clean all.

Si ni eso te funciona:

rm -fr /var/cache/yum/*

OJO: no borres en si /var/cache/yum. Solo sus contenidos. Ten cuidado al usar rm -fr.
 
Profile Email Website
 Quote
Oscar Hernández
 09/03/09 04:21PM  

Miembro Activo
working

Estado: desconectado
Forum User

Identificado: 03/29/07
Mensajes: 181
Localización:México D.F. /Del Alvaro Obregon

Gracias Maestro,

ya lo hice y no hace nada

ex ~]# yum -y update
Loaded plugins: fastestmirror, tmprepo
Determining fastest mirrors
Setting up Update Process
No Packages marked for Update


Cry Cry Cry

Sabio no es aquel que dedica su vida a aprender sino el que la dedica a enseñar.
 
Profile Email Website
 Quote
Joel Barrios Dueñas
 09/03/09 04:27PM  

Admin

Estado: desconectado
Site Admin

Identificado: 02/17/07
Mensajes: 1761
Localización:Mexico
Ya vi donde está tu problema. Abre cetOS-Base.repo, mira en base y updates, tienes enabled = 0, cambialo por enabled = 1.
 
Profile Email Website
 Quote
Oscar Hernández
 09/03/09 05:32PM  

Miembro Activo
working

Estado: desconectado
Forum User

Identificado: 03/29/07
Mensajes: 181
Localización:México D.F. /Del Alvaro Obregon


Ya lo hice pero ahora hace esto

ex /]# yum -y update
Loaded plugins: fastestmirror, tmprepo
Loading mirror speeds from cached hostfile
Could not retrieve mirrorlist http://mirrorlist.centos.org/?release=5&arch=i386&repo=os error was
[Errno 4] IOError: <urlopen error (-3, 'Fallo temporal en la resoluci\xc3\xb3n del nombre'Wink>
Error: Cannot find a valid baseurl for repo: base


Cry Cry Cry

Sabio no es aquel que dedica su vida a aprender sino el que la dedica a enseñar.
 
Profile Email Website
 Quote
Joel Barrios Dueñas
 09/03/09 06:53PM  

Admin

Estado: desconectado
Site Admin

Identificado: 02/17/07
Mensajes: 1761
Localización:Mexico
Revisa tu puerta de enlace y tus DNS. Ese error me indica que no tienes salida a Internet.
 
Profile Email Website
 Quote
Oscar Hernández
 09/04/09 05:41PM  

Miembro Activo
working

Estado: desconectado
Forum User

Identificado: 03/29/07
Mensajes: 181
Localización:México D.F. /Del Alvaro Obregon
Les cuento, ya lo solucione, pero fue algo raro, tuve que conectarlo al DSL directo y ponerlo como DHCP para que me diera una ip dinamica y ya se actualizo, una vez que se actualizo lo regrese con la ip fija que manejo y ahora si ya puedo salir como si nada hubiera pasado, es estraño no se si hubo algun daño en archivos pero al actualizarlo ya puedo usarlo como lo tenia detras de un Untangle, lo cual es raro porque el otro servidor esta funcionando sin problema.

Bueno Maestro Gracias por la ayuda y espero que Su Mamá este bien!!!

http://www.alcancelibre.org/article.php/20090904103141531

Big Grin Big Grin Big Grin

Sabio no es aquel que dedica su vida a aprender sino el que la dedica a enseñar.
 
Profile Email Website
 Quote
Oscar Hernández
 09/07/09 09:56AM  

Miembro Activo
working

Estado: desconectado
Forum User

Identificado: 03/29/07
Mensajes: 181
Localización:México D.F. /Del Alvaro Obregon
Hola ahora tengo el siguiente mensaje, no puedo actualizar

--> Processing Dependency: /usr/lib/python2.4 for package: gamin-python
--> Processing Dependency: /usr/lib/python2.4 for package: libxslt-python
--> Processing Dependency: /usr/lib/python2.4 for package: libxml2-python
--> Finished Dependency Resolution
gamin-python-0.1.7-8.el5.i386 from installed has depsolving problems
--> Missing Dependency: /usr/lib/python2.4 is needed by package gamin-python-0.1.7-8.el5.i386 (installed)
libxslt-python-1.1.17-2.el5_2.2.i386 from installed has depsolving problems
--> Missing Dependency: /usr/lib/python2.4 is needed by package libxslt-python-1.1.17-2.el5_2.2.i386 (installed)
libxml2-python-2.6.26-2.1.2.8.i386 from updates has depsolving problems
--> Missing Dependency: /usr/lib/python2.4 is needed by package libxml2-python-2.6.26-2.1.2.8.i386 (updates)
Error: Missing Dependency: /usr/lib/python2.4 is needed by package gamin-python-0.1.7-8.el5.i386 (installed)
Error: Missing Dependency: /usr/lib/python2.4 is needed by package libxslt-python-1.1.17-2.el5_2.2.i386 (installed)
Error: Missing Dependency: /usr/lib/python2.4 is needed by package libxml2-python-2.6.26-2.1.2.8.i386 (updates)


Cry Cry Cry

Sabio no es aquel que dedica su vida a aprender sino el que la dedica a enseñar.
 
Profile Email Website
 Quote
Joel Barrios Dueñas
 09/07/09 02:21PM  

Admin

Estado: desconectado
Site Admin

Identificado: 02/17/07
Mensajes: 1761
Localización:Mexico
Actualiza manualmente gamin-python, libxslt-python y libxml2-python. Parece que tuvieras algunos paquetes duplicados o estás actualizando desde un centOS 5.1 o 5.2. No te angusties, no pasa de acfualizar manualmente algunos paquetes. Ejemplo:

rpm -Uvh http://mirrors.kernel.org/centos/5/updates/i386/RPMS/libxml2-2.6.26-2.1.2.8.i386.rpm http://mirrors.kernel.org/centos/5/updates/i386/RPMS/libxml2-python-2.6.26-2.1.2.8.i386.rpm http://mirrors.kernel.org/centos/5/os/i386/CentOS/gamin-0.1.7-8.el5.i386.rpm http://mirrors.kernel.org/centos/5/os/i386/CentOS/gamin-python-0.1.7-8.el5.i386.rpm http://mirrors.kernel.org/centos/5/os/i386/CentOS/libxslt-1.1.17-2.el5_2.2.i386.rpm http://mirrors.kernel.org/centos/5/os/i386/CentOS/libxslt-python-1.1.17-2.el5_2.2.i386.rpm
 
Profile Email Website
 Quote
Joel Barrios Dueñas
 09/08/09 05:54PM  

Admin

Estado: desconectado
Site Admin

Identificado: 02/17/07
Mensajes: 1761
Localización:Mexico
Si lo anterior falla, ejecuta:
PHP Formatted Code
yum -y update --skip-broken
 
Profile Email Website
 Quote
Oscar Hernández
 09/09/09 10:32AM  

Miembro Activo
working

Estado: desconectado
Forum User

Identificado: 03/29/07
Mensajes: 181
Localización:México D.F. /Del Alvaro Obregon
Gracias Maestro, ya pude actualizar con esta ultima opcion

Mr. Green Mr. Green Mr. Green

Sabio no es aquel que dedica su vida a aprender sino el que la dedica a enseñar.
 
Profile Email Website
 Quote
Contenido generado en: 0.30 segundos New Topic Post Reply
 Todas las horas son CST. Hora actual 04:14 AM.
Tópico normal Tópico normal
Tópico Pegado Tópico Pegado
Tópico bloqueado Tópico bloqueado
Mensaje Nuevo Mensaje Nuevo
Tópico pegado con nuevo mensaje Tópico pegado con nuevo mensaje
Tópico bloqueado con nuevo mensaje Tópico bloqueado con nuevo mensaje
Ver mensajes anónimos 
Los usuarios anónimos pueden enviar 
Se permite HTML Filtrado 
Contenido censurado