Bienvenido(a) a Alcance Libre 01/10/2022, 14:55

Alcance Libre Foros

 Índice del foro > Todo acerca de Linux > Misceláneos New Topic Post Reply
 Actualizacion de Clamav
Tópico anterior Tópico siguiente
   
Juan Manuel Díaz
 10/05/07 11:38AM (Leído 4,403 veces)  

Nuevo

Estado: desconectado
Forum User

Identificado: 04/19/07
Mensajes: 13
tengo instalado Centos 5, cuando intento instalar la nueva versión de clamav se me produce el siguiente error

Error: clamav-filesystem conflicts with clamav > 0.91.2-1.11.el5.al
mi configuracion de repositorio de alcance libre es el siguiente:
[alcance-libre]
name=Alcance Libre para Enterprise Linux 5
baseurl=http://www.alcancelibre.org/al/el/5/
gpgkey=http://www.alcancelibre.org/al/AL-RPM-KEY

la instrucción yum es la siguiente
yum -y install clamav clamav-update clamav-data-empty

falta algo para poder actualizarla..... e intentado actualizarlo individualmente descargardo los rpm en el servidor y se produce el mismo error.

Gracias de antemano






 
Profile Email
 Quote
Joel Barrios Dueñas
 10/05/07 05:00PM  

Admin

Estado: desconectado
Site Admin

Identificado: 02/17/07
Mensajes: 1761
Localización:Mexico
¿Tienes otros depósitos dados de alta? en CentOS 5, la actualización es irrelevante, porque desde hace meses se utiliza la versión 0.92.x. Por favor, prueba instalar manualemente descargando los paquetes directamente del depósito.
 
Profile Email Website
 Quote
Juan Manuel Díaz
 10/08/07 09:07AM  

Nuevo

Estado: desconectado
Forum User

Identificado: 04/19/07
Mensajes: 13
Ya lo instente manualmente y se me produce una serie de error cada vez que intento actualizar un paquete.
los errores son los siguientes
la version que tengo instalada es la siguiente

[root@byrseg clamav]# rpm -q clamav
clamav-0.88.7-1.9.el4.lpt

error 1
[root@byrseg clamav]# rpm -Uvh clamav-0.91.2-1.11.el5.al.i386.rpm
error: Failed dependencies:
clamav-lib = 0.91.2-1.11.el5.al is needed by clamav-0.91.2-1.11.el5.al.i386
data(clamav) is needed by clamav-0.91.2-1.11.el5.al.i386
libclamav.so.2 is needed by clamav-0.91.2-1.11.el5.al.i386

error 2
[root@byrseg clamav]# rpm -Uvh clamav-lib-0.91.2-1.11.el5.al.i386.rpm
error: Failed dependencies:
data(clamav) is needed by clamav-lib-0.91.2-1.11.el5.al.i386

error 3
[root@byrseg clamav]# rpm -Uvh clamav-data-0.91.2-1.11.el5.al.i386.rpm
error: Failed dependencies:
clamav-filesystem = 0.91.2-1.11.el5.al is needed by clamav-data-0.91.2-1.11.el5.al.i386

error 4
[root@byrseg clamav]# rpm -Uvh clamav-filesystem-0.91.2-1.11.el5.al.i386.rpm
error: Failed dependencies:
fedora-usermgmt is needed by clamav-filesystem-0.91.2-1.11.el5.al.i386
clamav > 0.91.2-1.11.el5.al conflicts with clamav-filesystem-0.91.2-1.11.el5.al.i386


que mas pudiera hacer para poder actualizar el clamav
 
Profile Email
 Quote
David Rosado
 10/08/07 09:46AM  

Moderador

Estado: desconectado
Forum User

Identificado: 02/21/07
Mensajes: 154
Localización:Ecuador
Tienes instalado clamav-0.88.7-1.9.el4.lpt para CentOS 4 y quieres actualizar con un paquete de CentOS 5 Question
 
Profile Email
 Quote
Juan Manuel Díaz
 10/15/07 03:01PM  

Nuevo

Estado: desconectado
Forum User

Identificado: 04/19/07
Mensajes: 13
correcto. al momento que instale el servidor esa era la version que descargo con el yum, ahora quiero actulizarlo a la nueva version.

 
Profile Email
 Quote
Joel Barrios Dueñas
 10/17/07 10:10AM  

Admin

Estado: desconectado
Site Admin

Identificado: 02/17/07
Mensajes: 1761
Localización:Mexico
No instales uno por uno, sino instala TODOS al mismo tiempo.

clamav
clamav-lib
clamav-data-empty
clamav-filesystem

Es decir...

rpm -Uvh clamav-0.91.2-1.11.el5.al.i386.rpm clamav-lib-0.91.2-1.11.el5.al.i386.rpm clamav-data-empty-0.91.2-1.11.el5.al.i386.rpm clamav-filesystem-0.91.2-1.11.el5.al.i386.rpm
 
Profile Email Website
 Quote
Contenido generado en: 0.17 segundos New Topic Post Reply
 Todas las horas son CDT. Hora actual 02:55 PM.
Tópico normal Tópico normal
Tópico Pegado Tópico Pegado
Tópico bloqueado Tópico bloqueado
Mensaje Nuevo Mensaje Nuevo
Tópico pegado con nuevo mensaje Tópico pegado con nuevo mensaje
Tópico bloqueado con nuevo mensaje Tópico bloqueado con nuevo mensaje
Ver mensajes anónimos 
Los usuarios anónimos pueden enviar 
Se permite HTML Filtrado 
Contenido censurado