Bienvenido(a) a Alcance Libre 31/01/2023, 04:46

Alcance Libre Foros

 Índice del foro > Todo acerca de Linux > Redes y Servidores New Topic Post Reply
 Cambio MTU a 9000 en interface con bonding y VLAN_ID
Tópico anterior Tópico siguiente
   
Cami
 12/14/18 01:57PM (Leído 1,637 veces)  

Nuevo

Estado: desconectado
Forum User

Identificado: 12/14/18
Mensajes: 4
Buenas tardes:

Tengo un redhat 7.4 y he creado un bonding con dos interfaces que están configurados por VLAN_ID, ya que pasan varias VLANes por ahí y tengo que "tagearlas".

El problema es que necesito cambiar la MTU a 9000 y me da un error de fuera de rango. He puesto el parámetro en los interfaces y en el bonding, pero no los levantan. El Bonding aparece con MTU 9000, pero no lo levanta y tampoco los interfaces que forman parte del Bonding. Y los interfaces físicos siguen a MTU 1500.

He estado leyendo que con interfaces configurados con VLANes no se puede hacer, pero me parece súper raro que no se pueda.

¿Podéis ayudarme?

Gracias y un saludo
 
Profile Email
 Quote
Cami
 12/15/18 11:45AM  

Nuevo

Estado: desconectado
Forum User

Identificado: 12/14/18
Mensajes: 4
Esta es la configuración:

[root@XXXXXXXXX network-scripts]# cat ifcfg-bondHB521

##################Bonding de RAC. VLAN InterConnect

DEVICE=bondHB521

TYPE=Bond

BOOTPROTO=none

BONDING_MASTER=yes

ONBOOT=yes

DEFROUTE=no

name=bondHB521

IPADDR=172.XXX.XXX.XXX

PREFIX=28

[root@XXXXXXXXX network-scripts]# cat ifcfg-em3_2.521

############## Red de RAC. VLAN InterConnect

TYPE=Vlan

VLAN=yes

PHYSDEV=em3_2

VLAN_ID=521

PROXY_METHOD=none

BROWSER_ONLY=no

IPV4_FAILURE_FATAL=no

NAME=em3_2.521

UUID=bae51585-93c1-4ab3-9ed9-f1261b2f8f91

ONBOOT=yes

MASTER=bondHB521

SLAVE=yes


[root@XXXXXXXXX network-scripts]# cat ifcfg-em4_2.521

############## Red de RAC. VLAN InterConnect

TYPE=Vlan

VLAN=yes

PHYSDEV=em4_2

VLAN_ID=521

PROXY_METHOD=none

BROWSER_ONLY=no

IPV4_FAILURE_FATAL=no

NAME=em4_2.521

UUID=dd956a5b-bc80-4d80-b44a-6069a69cc128

ONBOOT=yes

MASTER=bondHB521

SLAVE=yes
 
Profile Email
 Quote
Cami
 12/16/18 01:08PM  

Nuevo

Estado: desconectado
Forum User

Identificado: 12/14/18
Mensajes: 4
Puse la variable MTU=9000 en los dos interfaces y en el bonding y no funcionó.

Después lo hice con "nmcli" cambiando el 802-3-ethernet.mtu a 9000, pero tampoco funcionó. Da el mismo error en los dos casos: fuera de rango.

Gracias
 
Profile Email
 Quote
Cami
 12/17/18 02:33AM  

Nuevo

Estado: desconectado
Forum User

Identificado: 12/14/18
Mensajes: 4
Siempre da el mismo error, lo haga como lo haga.


# ip link show dev bondHB525
26: bondHB525: <BROADCAST,MULTICAST,MASTER,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP mode DEFAULT qlen 1000
link/ether 54:48:10:1b:e3:53 brd ff:ff:ff:ff:ff:ff


# ip link set mtu 9000 dev bondHB525
RTNETLINK answers: Numerical result out of range
 
Profile Email
 Quote
Contenido generado en: 0.13 segundos New Topic Post Reply
 Todas las horas son CST. Hora actual 04:46 AM.
Tópico normal Tópico normal
Tópico Pegado Tópico Pegado
Tópico bloqueado Tópico bloqueado
Mensaje Nuevo Mensaje Nuevo
Tópico pegado con nuevo mensaje Tópico pegado con nuevo mensaje
Tópico bloqueado con nuevo mensaje Tópico bloqueado con nuevo mensaje
Ver mensajes anónimos 
Los usuarios anónimos pueden enviar 
Se permite HTML Filtrado 
Contenido censurado