Bienvenido(a) a Alcance Libre 30/01/2023, 13:16

Alcance Libre Foros

 Índice del foro > Todo acerca de Linux > Redes y Servidores New Topic Post Reply
 autorespuesta postfix y squirrelmail
Tópico anterior Tópico siguiente
   
perro006
 12/17/10 10:23AM (Leído 7,828 veces)  

Nuevo

Estado: desconectado
Forum User

Identificado: 11/17/10
Mensajes: 8
Hola amigos del foro:
No quería molestarlo pero no queria poner este post pero no me quedo otra opción, he buscado en la red información pero no me queda claro lo poco que encuentro, bueno mi problema es quizás para algunos re fácil, pero no he podido encontrar la respuesta, en fin no he podido configurar o colocar el mensaje de auto respuesta en postfix, se que dentro de la carpeta “/home” están los siguientes archivos
“.vacation.msg “tiene el siguiente texto de auto respuesta:
Subject: [Vacaciones]


Estimados (as):

Me encontrare de vacaciones hasta el lunes 15 de febrero, por favor ante cualquier contactarse al fono: xxxxxx

Gracias
Mr. Fulano

Le“.vacation.db” tiene código de máquina y él “.forward” , contiene:
\casilla, "|/usr/local/bin/vacation casilla"

El problema pasa que no he podido encontrar ningún comando que me asocie el mensaje al correo o si se hace por cada usuario de correo o es un mismo mensaje para todos, en fin los comandos no los he podido encontrar para hacerlo funcionar o si es que hay que reiniciar algún servicio o algo solo he encontrado información de que son estos los archivos y lo otro tampoco tengo el mensaje de auto respuesta en el squirrelmail se que ahí se puede instalar para dejar que auto responda pero tampoco sé que es para haberlo configurado desde hay , por favor necesito orientación y espero que me puedan ayudar muchas gracias.
 
Profile Email
 Quote
perro006
 12/17/10 02:41PM  

Nuevo

Estado: desconectado
Forum User

Identificado: 11/17/10
Mensajes: 8
Hola encontré que para esto serbia el comando “vacation” y he hecho lo siguiente:
En “/home”
#man vacation
y me dice que el comando a utilizar es
#vacation prueba
En donde prueba es una casilla de correo y solo queda en negro la parte de abajo del prompt escribo cosas pero no tima nada de nada, puse el comando al revés “prueba vacation” y no paso nada, lo he hecho dentro del home del usuario y tampoco, y cuando coloco
#usuario vacation
Me entra al man, si coloco “vacation” solo me entra a un editor tipo vi pero me lo tomo como root y no sé qué hacer, el “man” me dice que lo coloque “vaction nombreusuario” y aun así no pasa nada, e cargado el usuario y aun asi no lo toma, me pueden orientar en algo por favor, gracias.
 
Profile Email
 Quote
perro006
 12/20/10 03:09PM  

Nuevo

Estado: desconectado
Forum User

Identificado: 11/17/10
Mensajes: 8
Estimados:

les comento copie el .forward que tiene /root y lo pegue en /home/usuariovacaciones y ahí me responde pero no me dice nada el contenido del correo(el que debiera enviar de auto respuesta) aunque el .vacation.msg modifique para que dijera algo.

entre a ese mismo .forward y esta así dentro del /home del usuariodevacaciones:

\root, "|/usr/local/bin/vacation root"

Pero además me envía un correo tipo error que no está funcionando bien, pero después coloque

\usuariodevacaciones, "|/usr/local/bin/vacation usuariodevacaciones"

Y solo me envía el correo tipo error, es el siguiente:

This is the mail system at host servidor.servidor.cl.

I'm sorry to have to inform you that your message could not be delivered to one or more recipients. It's attached below.

For further assistance, please send mail to <postmaster>

If you do so, please include this problem report. You can delete your own text from the attached returned message.

The mail system

< usuariodevacaciones @dominio.cl>: Command died with status 1: "/usr/local/bin/vacation
prueba"

y adjunto a el este otro archivo:

Reporting-MTA: dns; servidor.servidor.cl
X-Postfix-Queue-ID: 104835C08A3
X-Postfix-Sender: rfc822; prueba@dominio.cl
Arrival-Date: Mon, 20 Dec 2010 17:07:36 -0300 (CLST)

Final-Recipient: rfc822; usuariodevacaciones@dominio.cl
Original-Recipient: rfc822;usuariodevacaciones@dominio.cl
Action: failed
Status: 5.3.0
Diagnostic-Code: x-unix; unknown mail system error 1


por favor, necesito que me orienten e perdido 3 dias sin resultados, espero que me puedan ayudar gracias.
 
Profile Email
 Quote
perro006
 12/29/10 09:24AM  

Nuevo

Estado: desconectado
Forum User

Identificado: 11/17/10
Mensajes: 8
Hola y gracias por leer .Primero que todo quiero reconocer que si cometí un error, pero ya borre el archivos que copie de root, los cuales eran”.fordward .vacation.msg”, instale “vacation” lo descargue de internet lo pase al servidor por FTP se llama el archivo” vacation-1.2.7.0.tar.gz”el cual leí que dentro de su archivo “install” o “readme” salen instrucciones de instalación según el programa, de todas maneras antes de instalarlo verifique si es que ya lo tenía instalado lo cual probé con “yum list vacation*” para que me mostrara si estaba instalado lo cual no me mostro nada de este archivo o paquete instalado, además probé con ”rpm –q vacation*.rpm” lo cual no me mostro nada, entonces procedí a instalar el ” vacation-1.2.7.0.tar.gz”en “/usr” lo descomprimí con “tar xvzf vacation-1.2.7.0.tar.gz” lo cual me creo una carpeta con el mismo nombre del archivo entre y escribí ”make” lo cual lo instalo supuestamente(esto decía los archivos de INSTALL y README) lo cual no me funciono, porque fui a la “/home/prueba” y escribí “vacation prueba” y nada , después entre a la sesión de prueba obviamente también dentro de su “/home” y escribí “vacation pueba” y nada, después solo “vacation” y nada pensé que me podría faltar algo y leí como se instala un tar.gz
http://www.eloihr.net/linux/index.php?page=compilar
y estando dentro de la carpeta donde lo instale ejecute “ make install” y me dio unos errores los cuales no los pude copiar para exponer porque se me serró la consola y realice las pruebas anteriormente dichas con el usuario “prueba” y no paso nada de nada, pero recordé que porque antes de instalarlo funcionaba en con el usuario root, entonces lo desinstale, me fui a “/usr” entre a la carpeta de “vacation-1.2.7.0” y escribí “make unistall” y me dio unos errores los cuales no pude copiar para exponer ya que se me cerro la consola, no sé porque, en fin después de todo eso me dije si no funciona no se qué hare y realice lo mismo de nuevo fui al “/home” del usuario prueba y coloque “vacation” y no pasaba nada intente de nuevo con “vacation prueba” y tampoco pasaba nada, cargue su sesión y coloque “vacation” y no pasaba nada intente de nuevo con “vacation prueba” entonces decidí ya que en root funciona entonces como, que ago. Y como dicen los manuales, que solo para que deje de funcionar hay que borrar el archivo”.forward” para que al ejecutar el “vacation” se re generara de nuevo y pueda funcionar, pero mejor borre los 3 archivos que genera ,es decir, “.forward .vacation.msg .vacation.db” y dentro de la sesión de prueba escribí “vacation” y hay funciono , tal cual como dicen los manuales , me abrió el editor vim mas un mensaje que está en ingles el cual hace referencia al mensaje que saldrá de rebote de vacaciones el cual modifique con mi idioma y el mansaje que quería lo guarde, realice las pruebas con mi cuenta de correo tanto una del mismo servidor como una de afuera y funciona, después borre el .forward y dejo de enviarlo( el mensaje de vacaciones), lo probé de nuevo con “vacation” modifique lo que me quedaba por modificar y realice las pruebas con mi correo, funcionaron y después las realice en los usuarios que realmente están de vacaciones como es aibarra y no presento ningún problema, la duda que me queda es que como trate de instalar yo el ” vacation-1.2.7.0” y que supuestamente quedo desinstalado lo podre borrar sin ningún problema como puedo ver esto para que no me mande problemas a fututo siendo que al desinstalarlo me envió errores igual, gracias.

Pd: espero haberme explicado bien, gracias.
 
Profile Email
 Quote
Joel Barrios Dueñas
 12/30/10 10:14AM  

Admin

Estado: desconectado
Site Admin

Identificado: 02/17/07
Mensajes: 1761
Localización:Mexico
 
Profile Email Website
 Quote
perro006
 12/30/10 02:56PM  

Nuevo

Estado: desconectado
Forum User

Identificado: 11/17/10
Mensajes: 8


Joel Barrios Dueñas:

Gracias por darte el tiempo de responder, te cuento, como dije en el post de arriba lo tengo funcionando el “vacation” pero no sé si es porque el que encontré o es porque el que estaba funcionando mal (lo dudo porque lo deciéntale el que encontre), muchísimas gracias por los link que me distes no sabía que había una versión especial para Centos, gracias, mi duda es podre borrar el “vacation” que quise instalar, que es un .tar.gz, me refiero a la carpeta que se genero al descomprimirlo, ya que al instalarlo se engancha por así decirlo al sistema, pero como dije anteriormente lo desinstale con “make uninstall” dentro de la carpeta que se genero tras la descompresión,

Pd: como veo si el “vacatio” que instale está inactivo para borrarlo, gracias.
 
Profile Email
 Quote
Contenido generado en: 0.18 segundos New Topic Post Reply
 Todas las horas son CST. Hora actual 01:16 PM.
Tópico normal Tópico normal
Tópico Pegado Tópico Pegado
Tópico bloqueado Tópico bloqueado
Mensaje Nuevo Mensaje Nuevo
Tópico pegado con nuevo mensaje Tópico pegado con nuevo mensaje
Tópico bloqueado con nuevo mensaje Tópico bloqueado con nuevo mensaje
Ver mensajes anónimos 
Los usuarios anónimos pueden enviar 
Se permite HTML Filtrado 
Contenido censurado