Bienvenido(a) a Alcance Libre 06/06/2023, 23:04

Alcance Libre Foros

 Índice del foro > Todo acerca de Linux > Redes y Servidores New Topic Post Reply
 squid+ clamav: clamd no responde
Tópico anterior Tópico siguiente
   
fjrojast
 05/27/10 07:20PM (Leído 1,979 veces)  

Nuevo

Estado: desconectado
Forum User

Identificado: 08/28/07
Mensajes: 5
Estoy en centos, con kernel 2.6.18-194.3.1.el5xen.


Según yo tengo ya compilado sin errores el squidclamav pues lo descargué de http://squidclamav.darold.net. Instalé los srpm de squid y con yum instalé curl, clamav y clamd. de manera que:

rpm -q clamav clamd curl squid
clamav-0.96.1-1.el5.rf
clamd-0.96.1-1.el5.rf
curl-7.15.5-9.el5
curl-7.15.5-9.el5
squid-2.6.STABLE21-6.el5

netstat -puta me dice para clamd:
(netstat dice: (tcp 0 0 localhost.local:dyna-access *:* LISTEN 1365/clamd)

Squid está trabajando perfectamente.

El problema es que squidclamav no conecta con clamd por ningún lado.
las opciones de configuración que he puesto han sido:

para conectar por socket:
clamd_local /var/run/clamav/clamd.sock

para conectar por ip
clamd_ip 192.168.1.252, 127.0.0.1
clamd_port 3310

y en el primer caso /var/log/squid/squidclamav.log me dice
ERROR Can't connect to clamd on local socket /tmp/clamd.
ERROR Can't connect to Clamd daemon, fallback to Squid.

en el segundo
ERROR Timeout connecting to 192.168.1.252:3310.
ERROR Can't lookup hostname of 127.0.0.1

haciendo la prueba desde la linea de comandos squiclamav, aparece lo siguiente:
[root@router ~]# squidclamav
SquidClamav v5.3 running in interactive mode
Fri May 28 18:26:16 2010 LOG Anonymizing User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1)
Fri May 28 18:26:16 2010 LOG SquidClamav v5.3 (PID 1903) started
http://www.slashdot.org/ 192.168.1.3/mypc.domain.dom mylog GET

http://www.eicar.org/download/eicar.com 192.168.1.3 mylog GET

cuando se suponía que me debía dar algo como esto:

Thu ... 2008 LOG Redirecting URL to: http://theproxy.com/cgi-bin/clwarn.cgi?url=http://www.eicar.org/download/eicar.com&source=192.168.1.3&user=mylog&virus=stream:+Eicar-Test-Signature+FOUND
http://theproxy.com/cgi-bin/clwarn.cgi?url=http://www.eicar.org/download/eicar.com&source=192.168.1.3&user=mylog&virus=stream:+Eicar-Test-Signature+FOUND 192.168.1.3 mylog GET




con dmesg he observado que aparece esto:
squidclamav[1605]: segfault at 0000000000000000 rip 0000000000000000 rsp 00007ffff66cccd0 error 14


¿alguna sugerencia para echar a andar esta cosa?




 
Profile Email
 Quote
Contenido generado en: 0.05 segundos New Topic Post Reply
 Todas las horas son CST. Hora actual 11:04 PM.
Tópico normal Tópico normal
Tópico Pegado Tópico Pegado
Tópico bloqueado Tópico bloqueado
Mensaje Nuevo Mensaje Nuevo
Tópico pegado con nuevo mensaje Tópico pegado con nuevo mensaje
Tópico bloqueado con nuevo mensaje Tópico bloqueado con nuevo mensaje
Ver mensajes anónimos 
Los usuarios anónimos pueden enviar 
Se permite HTML Filtrado 
Contenido censurado