Bienvenido(a) a Alcance Libre 29/01/2023, 09:11

Alcance Libre Foros

 Índice del foro > Todo acerca de Linux > Programas y Aplicaciones New Topic Post Reply
 Error con libsqlite3.so.0
Tópico anterior Tópico siguiente
   
Will Lpz Jimnz
 12/03/07 09:32PM (Leído 3,246 veces)  

Admin

Estado: desconectado
Site Admin

Identificado: 02/19/07
Mensajes: 181
Localización:Mexico
buenas .. después de hacer una actualización al sistema con ..

PHP Formatted Code
yum -y update


y seguidamente reiniciar por completo .. me tope con esto ..

Ahora queria limpiar el cache de yum para las instalaciones futuras y me aparece esto ..
PHP Formatted Code
# yum clean all
There was a problem importing one of the Python modules
required to run yum. The error leading to this problem was:

   libsqlite3.so.0: cannot open shared object file: No such file or directory

Please install a package which provides this module, or
verify that the module is installed correctly.

It's possible that the above module doesn't match the
current version of Python, which is:
2.4.3 (#1, Mar 14 2007, 18:51:08)
[GCC 4.1.1 20070105 (Red Hat 4.1.1-52)]

If you cannot solve this problem yourself, please go to
the yum faq at:
  http://wiki.linux.duke.edu/YumFaq
 


Segun el foro de CentOs 5 nos dice que la solución es reinstalar el paquete Sqlite con el parámetro --force .. el detalle es que ni siquiera puedo instalar un paquete .. me sucede esto .

PHP Formatted Code
# rpm -Uvh http://www.alcancelibre.org/al/el/5/RPMS.al/sqlite-3.3.13-1.9.el5.al.i386.rpm --force
rpm: error while loading shared libraries: libsqlite3.so.0: cannot open shared object file: No such file or directory


según noto me falta la librería libsqlite3.so.0 .. pero no puedo instalar nada pues me sale el mensaje mostrado con anterioridad.
alguna sugerencia para poder instalar esta biblioteca o algo que haya que hacer para resolver esto ?

Saludos !! Mr. Green

.:: Cuando el Alumno esta listo, el maestro aparece ::. [[http://koalasoft.wordpress.com ::BLog::]]
 
Profile Email Website
 Quote
Will Lpz Jimnz
 12/05/07 02:40PM  

Admin

Estado: desconectado
Site Admin

Identificado: 02/19/07
Mensajes: 181
Localización:Mexico
Aqui la respuesta sobre la bliblioteca libsqlite3

Primeramente me enviaron buscar el paquete rpm2cpio .. bueno el sistema ya lo traía instalado pero no me funcionaba, asi que busque el código perl de este.
Lo pueden ver en este enlace, fue el que use:
PHP Formatted Code
http://linuxmafia.com/pub/linux/utilities-general/rpm2cpio


A continuación .. lo natural darle os permisos:

PHP Formatted Code
chmod +x rpm2cpio.pl


un aves hecho esto cree los directorio de instalación para ver que archivo utiliza tal paquete y ver cual me faltaba.
Con anterioridad ya había bajado el paquete sqlite.
Se hizo de la siguiente forma:

PHP Formatted Code
# ./rpm2cpio.pl sqlite-3.3.13-1.9.el5.al.i386.rpm | cpio -iduv
CPIO archive found!
./usr/bin/sqlite3
./usr/lib/libsqlite3.so.0
./usr/lib/libsqlite3.so.0.8.6
./usr/share/doc/sqlite-3.3.13
./usr/share/doc/sqlite-3.3.13/README
./usr/share/man/man1/sqlite3.1.gz
2606 blocks


Ya con esto tuve la estructura de donde estaban los paquetes que necesitaba y si me faltaba alguno.
checando en mi sistema localice lo siguiente:

PHP Formatted Code
ls usr/lib/
libsqlite3.so.0  libsqlite3.so.0.8.6


Pero al parecer el enlce o el paquete se daño, así que los archivos descompactados con el rpm2cpio los use en mi sistema como si fueran una instalación normal, realice los siguiente:

elimine los que tenia en mi sistema:

PHP Formatted Code
# rm /usr/lib/libsqlite3.so*
rm: ¿borrar el enlace simbólico «/usr/lib/libsqlite3.so»? (s/n) s
rm: ¿borrar el archivo regular «/usr/lib/libsqlite3.so.0.8.6»? (s/n) s


Y después copie los nuevos (que descompacte con el rpm2cpio) en sus respectivos directorios:

PHP Formatted Code
# cp -R usr/lib/libsqlite3.so.0* /usr/lib/


y una vez hecho esto, ya puedo utilizar el comando rpm ..

PHP Formatted Code
]# rpm -qa | grep sqlite
qt4-sqlite-4.2.3-10.9.el5.al
sqlite-devel-3.3.13-1.9.el5.al
mono-data-sqlite-1.2.3.1-1.9.el5.al
python-sqlite-1.1.7-1.2.9.el4.lpt


cosa que antes no se podía,

Gracias a los que ayudaron en esta tarea, algún detalle mantendré informado.

Saludos !! Mr. Green

.:: Cuando el Alumno esta listo, el maestro aparece ::. [[http://koalasoft.wordpress.com ::BLog::]]
 
Profile Email Website
 Quote
Contenido generado en: 0.28 segundos New Topic Post Reply
 Todas las horas son CST. Hora actual 09:11 AM.
Tópico normal Tópico normal
Tópico Pegado Tópico Pegado
Tópico bloqueado Tópico bloqueado
Mensaje Nuevo Mensaje Nuevo
Tópico pegado con nuevo mensaje Tópico pegado con nuevo mensaje
Tópico bloqueado con nuevo mensaje Tópico bloqueado con nuevo mensaje
Ver mensajes anónimos 
Los usuarios anónimos pueden enviar 
Se permite HTML Filtrado 
Contenido censurado